ClassNotFoundException in thread

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

ClassNotFoundException in thread

Cyril.ZEKSER
Hi all,

I've just migrated my appservers from HP-UX to Linux RedHat AS4, and I'm
now stuck with a strange issue :

I've 2 jar in the WEB-INF/lib directory  (common.jar and statistic.jar).

The common.jar contains a Watchdog that seek in the DB for job to run,
start them, and those jobs are looking for classes by reflection to handle
the process to be done.

The statistic.jar package contains the classes that handle the process to
be done.

Everything was fin until I migrated. Now the jobs run OK but they fire a
ClassNotFoundException as shwon :

java.lang.ClassNotFoundException:
com.nexans.statistic.client.model.send.intranet.handler.CreateFileProcedure
        at java.net.URLClassLoader$1.run(URLClassLoader.java:199)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
        at
com.nexans.common.alert.businessmodel.jdbc.AlertJobImpl.run(AlertJobImpl.java:466)
        at java.lang.Thread.run(Thread.java:534)

The problem persists when I extract the classes in the jar into
WEB-INF/classes. So now I don't know what to do next and where to search.

Does anyone have an idea ?

I'm using Tomcat 4.1.31+ mod_jk 1.10  (was using tomcat 4.1.30 and jk2 on
HP-ux, but I quite sure the problem is not there...)
with
java version "1.4.2_07"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_07-b05)
Java HotSpot(TM) Client VM (build 1.4.2_07-b05, mixed mode)

on RH

and

java version "1.4.1.03"
Java(TM) 2 Runtime Environment, Standard Edition (build
1.4.1.03-030630-19:37)
Java HotSpot(TM) Server VM (build 1.4.1 1.4.1.03-030630-22:07-PA_RISC2.0
PA2.0, mixed mode)

on HP-UX

Thanks in advance

Cyril ZEKSER




---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: ClassNotFoundException in thread

Anto Paul
On 6/2/05, [hidden email] <[hidden email]> wrote:
>
> Everything was fin until I migrated. Now the jobs run OK but they fire a
> ClassNotFoundException as shwon :
>

You double  checked that
com.nexans.statistic.client.model.send.intranet.handler.CreateFileProcedure
is there in the jar and is in the right folder ?. Restarted Tomcat ?.
Also try with a fresh copy of the jar.
--
rgds
Anto Paul

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]