Java 11 support in Apache Tomcat 9.0

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Java 11 support in Apache Tomcat 9.0

Shailendra Kumar Verma
Hello,

When we run Tomcat 9.0.12 installer, it prompts to provide JRE location. Since Java 11 LTS release yesterday does NOT have any JRE installer separately, all it has server JVM embedded in it under <jdk-11\bin\server>. If I give this path where jvm.dll located under server folder, it does not recognize.

Whats' the plan for Java 11 for Apache Tomcat 9.0?

Thanks,
Shailendra

NOTICE: The information contained in this electronic mail transmission is intended by Convergys Corporation for the use of the named individual or entity to which it is directed and may contain information that is privileged or otherwise confidential. If you have received this electronic mail transmission in error, please delete it from your system without copying or forwarding it, and notify the sender of the error by reply email or by telephone (collect), so that the sender's address records can be corrected.
Reply | Threaded
Open this post in threaded view
|

Re: Java 11 support in Apache Tomcat 9.0

Johan Compagner
Just wondering how do you get a JRE?
oracle doesnt provide one anymore (and the JDK that you can download can
only really be used for development and nothing else)

so are you using the open source JDK?


On Wed, 26 Sep 2018 at 13:40, Shailendra Kumar Verma <
[hidden email]> wrote:

> Hello,
>
> When we run Tomcat 9.0.12 installer, it prompts to provide JRE location.
> Since Java 11 LTS release yesterday does NOT have any JRE installer
> separately, all it has server JVM embedded in it under <jdk-11\bin\server>.
> If I give this path where jvm.dll located under server folder, it does not
> recognize.
>
> Whats' the plan for Java 11 for Apache Tomcat 9.0?
>
> Thanks,
> Shailendra
>
> NOTICE: The information contained in this electronic mail transmission is
> intended by Convergys Corporation for the use of the named individual or
> entity to which it is directed and may contain information that is
> privileged or otherwise confidential. If you have received this electronic
> mail transmission in error, please delete it from your system without
> copying or forwarding it, and notify the sender of the error by reply email
> or by telephone (collect), so that the sender's address records can be
> corrected.
>


--
Johan Compagner
Servoy
Reply | Threaded
Open this post in threaded view
|

RE: Java 11 support in Apache Tomcat 9.0

Shailendra Kumar Verma
Johan,

That's what I am saying. All we have now, jvm.dll that comes under jdk-11\bin\server\jvm.dll. No JRE is released from Java 11 now.

Thanks,
Shailendra

-----Original Message-----
From: Johan Compagner <[hidden email]>
Sent: Wednesday, September 26, 2018 5:28 PM
To: Tomcat Users List <[hidden email]>
Subject: Re: Java 11 support in Apache Tomcat 9.0

***CAUTION: This email originated from outside of the organization. Do not open attachments or click links unless you recognize sender and know content is safe.*** Forward suspicious email to [hidden email] ___________________________________________________________________

Just wondering how do you get a JRE?
oracle doesnt provide one anymore (and the JDK that you can download can only really be used for development and nothing else)

so are you using the open source JDK?


On Wed, 26 Sep 2018 at 13:40, Shailendra Kumar Verma < [hidden email]> wrote:

> Hello,
>
> When we run Tomcat 9.0.12 installer, it prompts to provide JRE location.
> Since Java 11 LTS release yesterday does NOT have any JRE installer
> separately, all it has server JVM embedded in it under <jdk-11\bin\server>.
> If I give this path where jvm.dll located under server folder, it does
> not recognize.
>
> Whats' the plan for Java 11 for Apache Tomcat 9.0?
>
> Thanks,
> Shailendra
>
> NOTICE: The information contained in this electronic mail transmission
> is intended by Convergys Corporation for the use of the named
> individual or entity to which it is directed and may contain
> information that is privileged or otherwise confidential. If you have
> received this electronic mail transmission in error, please delete it
> from your system without copying or forwarding it, and notify the
> sender of the error by reply email or by telephone (collect), so that
> the sender's address records can be corrected.
>


--
Johan Compagner
Servoy
NOTICE: The information contained in this electronic mail transmission is intended by Convergys Corporation for the use of the named individual or entity to which it is directed and may contain information that is privileged or otherwise confidential. If you have received this electronic mail transmission in error, please delete it from your system without copying or forwarding it, and notify the sender of the error by reply email or by telephone (collect), so that the sender's address records can be corrected.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: Java 11 support in Apache Tomcat 9.0

markt
Tomcat already supports Java 11 and has done for some time.

You need to point the installer to the root of the jdk-11 install.

If you install the Orcale JDK, the installer will find it via the
registry. If you use OpenJDK you'll need to select the root of the
install (a.k.a. JAVA_HOME) yourself.

Mark



On 26/09/2018 08:01, Shailendra Kumar Verma wrote:

> Johan,
>
> That's what I am saying. All we have now, jvm.dll that comes under jdk-11\bin\server\jvm.dll. No JRE is released from Java 11 now.
>
> Thanks,
> Shailendra
>
> -----Original Message-----
> From: Johan Compagner <[hidden email]>
> Sent: Wednesday, September 26, 2018 5:28 PM
> To: Tomcat Users List <[hidden email]>
> Subject: Re: Java 11 support in Apache Tomcat 9.0
>
> ***CAUTION: This email originated from outside of the organization. Do not open attachments or click links unless you recognize sender and know content is safe.*** Forward suspicious email to [hidden email] ___________________________________________________________________
>
> Just wondering how do you get a JRE?
> oracle doesnt provide one anymore (and the JDK that you can download can only really be used for development and nothing else)
>
> so are you using the open source JDK?
>
>
> On Wed, 26 Sep 2018 at 13:40, Shailendra Kumar Verma < [hidden email]> wrote:
>
>> Hello,
>>
>> When we run Tomcat 9.0.12 installer, it prompts to provide JRE location.
>> Since Java 11 LTS release yesterday does NOT have any JRE installer
>> separately, all it has server JVM embedded in it under <jdk-11\bin\server>.
>> If I give this path where jvm.dll located under server folder, it does
>> not recognize.
>>
>> Whats' the plan for Java 11 for Apache Tomcat 9.0?
>>
>> Thanks,
>> Shailendra
>>
>> NOTICE: The information contained in this electronic mail transmission
>> is intended by Convergys Corporation for the use of the named
>> individual or entity to which it is directed and may contain
>> information that is privileged or otherwise confidential. If you have
>> received this electronic mail transmission in error, please delete it
>> from your system without copying or forwarding it, and notify the
>> sender of the error by reply email or by telephone (collect), so that
>> the sender's address records can be corrected.
>>
>
>
> --
> Johan Compagner
> Servoy
> NOTICE: The information contained in this electronic mail transmission is intended by Convergys Corporation for the use of the named individual or entity to which it is directed and may contain information that is privileged or otherwise confidential. If you have received this electronic mail transmission in error, please delete it from your system without copying or forwarding it, and notify the sender of the error by reply email or by telephone (collect), so that the sender's address records can be corrected.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

RE: Java 11 support in Apache Tomcat 9.0

Shailendra Kumar Verma
Okay, so we have to provide root of jdk11 install when prompted at time of installation.

Since JDK includes compiler and PCI compliance does not allow it. What if we install custom runtime using "jlink" instead of "full JDK11? Will Apache Tomcat gets install if we give path of jlink installed custom runtime that includes jvm.dll?

Thanks,
Shailendra


-----Original Message-----
From: Mark Thomas <[hidden email]>
Sent: Wednesday, September 26, 2018 7:36 PM
To: [hidden email]
Subject: Re: Java 11 support in Apache Tomcat 9.0

***CAUTION: This email originated from outside of the organization. Do not open attachments or click links unless you recognize sender and know content is safe.*** Forward suspicious email to [hidden email] ___________________________________________________________________

Tomcat already supports Java 11 and has done for some time.

You need to point the installer to the root of the jdk-11 install.

If you install the Orcale JDK, the installer will find it via the registry. If you use OpenJDK you'll need to select the root of the install (a.k.a. JAVA_HOME) yourself.

Mark



On 26/09/2018 08:01, Shailendra Kumar Verma wrote:

> Johan,
>
> That's what I am saying. All we have now, jvm.dll that comes under jdk-11\bin\server\jvm.dll. No JRE is released from Java 11 now.
>
> Thanks,
> Shailendra
>
> -----Original Message-----
> From: Johan Compagner <[hidden email]>
> Sent: Wednesday, September 26, 2018 5:28 PM
> To: Tomcat Users List <[hidden email]>
> Subject: Re: Java 11 support in Apache Tomcat 9.0
>
> ***CAUTION: This email originated from outside of the organization. Do
> not open attachments or click links unless you recognize sender and
> know content is safe.*** Forward suspicious email to
> [hidden email]
> ___________________________________________________________________
>
> Just wondering how do you get a JRE?
> oracle doesnt provide one anymore (and the JDK that you can download
> can only really be used for development and nothing else)
>
> so are you using the open source JDK?
>
>
> On Wed, 26 Sep 2018 at 13:40, Shailendra Kumar Verma < [hidden email]> wrote:
>
>> Hello,
>>
>> When we run Tomcat 9.0.12 installer, it prompts to provide JRE location.
>> Since Java 11 LTS release yesterday does NOT have any JRE installer
>> separately, all it has server JVM embedded in it under <jdk-11\bin\server>.
>> If I give this path where jvm.dll located under server folder, it
>> does not recognize.
>>
>> Whats' the plan for Java 11 for Apache Tomcat 9.0?
>>
>> Thanks,
>> Shailendra
>>
>> NOTICE: The information contained in this electronic mail
>> transmission is intended by Convergys Corporation for the use of the
>> named individual or entity to which it is directed and may contain
>> information that is privileged or otherwise confidential. If you have
>> received this electronic mail transmission in error, please delete it
>> from your system without copying or forwarding it, and notify the
>> sender of the error by reply email or by telephone (collect), so that
>> the sender's address records can be corrected.
>>
>
>
> --
> Johan Compagner
> Servoy
> NOTICE: The information contained in this electronic mail transmission is intended by Convergys Corporation for the use of the named individual or entity to which it is directed and may contain information that is privileged or otherwise confidential. If you have received this electronic mail transmission in error, please delete it from your system without copying or forwarding it, and notify the sender of the error by reply email or by telephone (collect), so that the sender's address records can be corrected.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

NOTICE: The information contained in this electronic mail transmission is intended by Convergys Corporation for the use of the named individual or entity to which it is directed and may contain information that is privileged or otherwise confidential. If you have received this electronic mail transmission in error, please delete it from your system without copying or forwarding it, and notify the sender of the error by reply email or by telephone (collect), so that the sender's address records can be corrected.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: Java 11 support in Apache Tomcat 9.0

Johan Compagner
but if you talk about a jlink thing isn't it then the idea that it it
includes it all so including tomcat and maybe even the webapp that you want
to run on it?


On Wed, 26 Sep 2018 at 16:19, Shailendra Kumar Verma <
[hidden email]> wrote:

> Okay, so we have to provide root of jdk11 install when prompted at time of
> installation.
>
> Since JDK includes compiler and PCI compliance does not allow it. What if
> we install custom runtime using "jlink" instead of "full JDK11? Will Apache
> Tomcat gets install if we give path of jlink installed custom runtime that
> includes jvm.dll?
>
> Thanks,
> Shailendra
>
>
> -----Original Message-----
> From: Mark Thomas <[hidden email]>
> Sent: Wednesday, September 26, 2018 7:36 PM
> To: [hidden email]
> Subject: Re: Java 11 support in Apache Tomcat 9.0
>
> ***CAUTION: This email originated from outside of the organization. Do not
> open attachments or click links unless you recognize sender and know
> content is safe.*** Forward suspicious email to [hidden email]
> ___________________________________________________________________
>
> Tomcat already supports Java 11 and has done for some time.
>
> You need to point the installer to the root of the jdk-11 install.
>
> If you install the Orcale JDK, the installer will find it via the
> registry. If you use OpenJDK you'll need to select the root of the install
> (a.k.a. JAVA_HOME) yourself.
>
> Mark
>
>
>
> On 26/09/2018 08:01, Shailendra Kumar Verma wrote:
> > Johan,
> >
> > That's what I am saying. All we have now, jvm.dll that comes under
> jdk-11\bin\server\jvm.dll. No JRE is released from Java 11 now.
> >
> > Thanks,
> > Shailendra
> >
> > -----Original Message-----
> > From: Johan Compagner <[hidden email]>
> > Sent: Wednesday, September 26, 2018 5:28 PM
> > To: Tomcat Users List <[hidden email]>
> > Subject: Re: Java 11 support in Apache Tomcat 9.0
> >
> > ***CAUTION: This email originated from outside of the organization. Do
> > not open attachments or click links unless you recognize sender and
> > know content is safe.*** Forward suspicious email to
> > [hidden email]
> > ___________________________________________________________________
> >
> > Just wondering how do you get a JRE?
> > oracle doesnt provide one anymore (and the JDK that you can download
> > can only really be used for development and nothing else)
> >
> > so are you using the open source JDK?
> >
> >
> > On Wed, 26 Sep 2018 at 13:40, Shailendra Kumar Verma <
> [hidden email]> wrote:
> >
> >> Hello,
> >>
> >> When we run Tomcat 9.0.12 installer, it prompts to provide JRE location.
> >> Since Java 11 LTS release yesterday does NOT have any JRE installer
> >> separately, all it has server JVM embedded in it under
> <jdk-11\bin\server>.
> >> If I give this path where jvm.dll located under server folder, it
> >> does not recognize.
> >>
> >> Whats' the plan for Java 11 for Apache Tomcat 9.0?
> >>
> >> Thanks,
> >> Shailendra
> >>
> >> NOTICE: The information contained in this electronic mail
> >> transmission is intended by Convergys Corporation for the use of the
> >> named individual or entity to which it is directed and may contain
> >> information that is privileged or otherwise confidential. If you have
> >> received this electronic mail transmission in error, please delete it
> >> from your system without copying or forwarding it, and notify the
> >> sender of the error by reply email or by telephone (collect), so that
> >> the sender's address records can be corrected.
> >>
> >
> >
> > --
> > Johan Compagner
> > Servoy
> > NOTICE: The information contained in this electronic mail transmission
> is intended by Convergys Corporation for the use of the named individual or
> entity to which it is directed and may contain information that is
> privileged or otherwise confidential. If you have received this electronic
> mail transmission in error, please delete it from your system without
> copying or forwarding it, and notify the sender of the error by reply email
> or by telephone (collect), so that the sender's address records can be
> corrected.
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
> NOTICE: The information contained in this electronic mail transmission is
> intended by Convergys Corporation for the use of the named individual or
> entity to which it is directed and may contain information that is
> privileged or otherwise confidential. If you have received this electronic
> mail transmission in error, please delete it from your system without
> copying or forwarding it, and notify the sender of the error by reply email
> or by telephone (collect), so that the sender's address records can be
> corrected.
>


--
Johan Compagner
Servoy
Reply | Threaded
Open this post in threaded view
|

Re: Java 11 support in Apache Tomcat 9.0

Christopher Schultz-2
In reply to this post by Shailendra Kumar Verma
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Shailendra,

On 9/26/18 10:19, Shailendra Kumar Verma wrote:
> Okay, so we have to provide root of jdk11 install when prompted at
> time of installation.
>
> Since JDK includes compiler and PCI compliance does not allow it.

Can you please provide a reference to that PCI item?

Thanks,
- -chris

> -----Original Message----- From: Mark Thomas <[hidden email]>
> Sent: Wednesday, September 26, 2018 7:36 PM To:
> [hidden email] Subject: Re: Java 11 support in Apache
> Tomcat 9.0
>
> ***CAUTION: This email originated from outside of the organization.
> Do not open attachments or click links unless you recognize sender
> and know content is safe.*** Forward suspicious email to
> [hidden email]
> ___________________________________________________________________
>
>  Tomcat already supports Java 11 and has done for some time.
>
> You need to point the installer to the root of the jdk-11 install.
>
> If you install the Orcale JDK, the installer will find it via the
> registry. If you use OpenJDK you'll need to select the root of the
> install (a.k.a. JAVA_HOME) yourself.
>
> Mark
>
>
>
> On 26/09/2018 08:01, Shailendra Kumar Verma wrote:
>> Johan,
>>
>> That's what I am saying. All we have now, jvm.dll that comes
>> under jdk-11\bin\server\jvm.dll. No JRE is released from Java 11
>> now.
>>
>> Thanks, Shailendra
>>
>> -----Original Message----- From: Johan Compagner
>> <[hidden email]> Sent: Wednesday, September 26, 2018 5:28
>> PM To: Tomcat Users List <[hidden email]> Subject: Re:
>> Java 11 support in Apache Tomcat 9.0
>>
>> ***CAUTION: This email originated from outside of the
>> organization. Do not open attachments or click links unless you
>> recognize sender and know content is safe.*** Forward suspicious
>> email to [hidden email]
>> ___________________________________________________________________
>>
>>
>>
Just wondering how do you get a JRE?

>> oracle doesnt provide one anymore (and the JDK that you can
>> download can only really be used for development and nothing
>> else)
>>
>> so are you using the open source JDK?
>>
>>
>> On Wed, 26 Sep 2018 at 13:40, Shailendra Kumar Verma <
>> [hidden email]> wrote:
>>
>>> Hello,
>>>
>>> When we run Tomcat 9.0.12 installer, it prompts to provide JRE
>>> location. Since Java 11 LTS release yesterday does NOT have any
>>> JRE installer separately, all it has server JVM embedded in it
>>> under <jdk-11\bin\server>. If I give this path where jvm.dll
>>> located under server folder, it does not recognize.
>>>
>>> Whats' the plan for Java 11 for Apache Tomcat 9.0?
>>>
>>> Thanks, Shailendra
>>>
>>> NOTICE: The information contained in this electronic mail
>>> transmission is intended by Convergys Corporation for the use
>>> of the named individual or entity to which it is directed and
>>> may contain information that is privileged or otherwise
>>> confidential. If you have received this electronic mail
>>> transmission in error, please delete it from your system
>>> without copying or forwarding it, and notify the sender of the
>>> error by reply email or by telephone (collect), so that the
>>> sender's address records can be corrected.
>>>
>>
>>
>> -- Johan Compagner Servoy NOTICE: The information contained in
>> this electronic mail transmission is intended by Convergys
>> Corporation for the use of the named individual or entity to
>> which it is directed and may contain information that is
>> privileged or otherwise confidential. If you have received this
>> electronic mail transmission in error, please delete it from your
>> system without copying or forwarding it, and notify the sender of
>> the error by reply email or by telephone (collect), so that the
>> sender's address records can be corrected.
>>
>> ---------------------------------------------------------------------
>>
>>
To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>
> ---------------------------------------------------------------------
>
>
To unsubscribe, e-mail: [hidden email]

> For additional commands, e-mail: [hidden email]
>
> NOTICE: The information contained in this electronic mail
> transmission is intended by Convergys Corporation for the use of
> the named individual or entity to which it is directed and may
> contain information that is privileged or otherwise confidential.
> If you have received this electronic mail transmission in error,
> please delete it from your system without copying or forwarding it,
> and notify the sender of the error by reply email or by telephone
> (collect), so that the sender's address records can be corrected.
>
> ---------------------------------------------------------------------
>
>
To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
-----BEGIN PGP SIGNATURE-----
Comment: Using GnuPG with Thunderbird - https://www.enigmail.net/

iQIzBAEBCAAdFiEEMmKgYcQvxMe7tcJcHPApP6U8pFgFAlur4J4ACgkQHPApP6U8
pFgwHQ//es6cFQBV3sB/Qr6jGrTyYm9Vpu0e8vJvT0/MY0yDLBGbyj373Oj9ATh9
p0WFHynwdIkZFql4fQNJB+VSfCKI7aZ+flfnbWrnmKjpNdTRMmtJaV/FCAVtYx69
CPdz8pbHWx9uBRAc7iY/LkxGL5CmYXjxVahR+pGgp+cODHwEVygLY2yuyGwnsdyA
WvAQwqq1lAk4+DBsUVyGpUSqcc1pX3637XEXI9+ZS6mBVvokFkNVytmFwfsWFQYL
2krMC3mTVYUK9Lf1mIONEWDfPPiLuJS9bagiqMvleqGKPqr4kiTgk5i5HGNOSW1P
z1Vo7j4iGPpYJpXO9vUOn2/jyuT0kVye6wikX/AoI6fsaPqzwOODMdef+1MqRS3A
HgQ/no/Zlblm32M8Ab+espbFB5QK3/a2agjk61I4+5nsSIIzqbMTzwMD2BzsZ9r2
hnoIiHmmYK0DiIHRyLVjzTqNd8xR7ia4UqfVJco1d6LZv7YDOWgIHi4nO0S0aJyD
n/cpKFNLRpuvZHVLwmGxOKac8YfnISO9wnwIFcC0wNvIPAzjXSEGSNhX9PHo7Ssc
nIuQCt5DVUTyGM7Yb/usJZQ0FRk4JIU1sKiu/1uQp+O6JR52eDKvIMondNN3lHne
9yk5+URfqpfdkchind14dmaCj8WoLytDGysR2PbwDI4ge7k9BCE=
=iS0L
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]