Problem with Tomcat upgrade to 5.0.28 from 4.x

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem with Tomcat upgrade to 5.0.28 from 4.x

Devireddy, Nagendra Reddy (STSD)
Hi,

I have upgraded tomcat from 4.x to 5.0.
This is how I hv done the upgrade ..
I took backup of webapps/test_apps
Installed Tomcat 5.0 and
Then I copied the test_apps to the new webapps

I have not changed any thing else ..

Tomcat is throwing class defination not found error .. But I searched
for the same class and its available in
test_apps/WEB-INF/lib/test_apps.jar

Do we need to change web.xml ?? Or the same which was working with 4.0
will work here ??

Is there any extra configuration needs to be changed ??

Please help me ..

Thanks,
Nagendra

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

RE: Problem with Tomcat upgrade to 5.0.28 from 4.x

Awaneesh Shatmanyu
Hi Nagendra,

 

I had the similar problem......its fine now......

You need to change the <servlet-class> in web.xml in Tomcat 5.x ....

Please Follow below........

 

In Tomcat 4.1...the web.xml had the following <servlet-class>for
ActionServlet.....

<servlet>

        <servlet-name>ActionServlet</servlet-name>

 
<servlet-class>com/NRI/TStar/servlets/ActionServlet</servlet-class>

    </servlet>

       <servlet-mapping>

        <servlet-name>ActionServlet</servlet-name>

        <url-pattern>/com/NRI/TStar/servlets/ActionServlet</url-pattern>

    </servlet-mapping>

 

When I upgraded it to Tomcat 5.x...the web.xml should be.........for the
<servlet-class>..

<servlet>

        <servlet-name>ActionServlet</servlet-name>

 
<servlet-class>com.NRI.TStar.servlets.ActionServlet</servlet-class>

    </servlet>

    <servlet-mapping>

        <servlet-name>ActionServlet</servlet-name>

        <url-pattern>/com/NRI/TStar/servlets/ActionServlet</url-pattern>

    </servlet-mapping>

 

Use .(dot) instead of /

I hope this should solve the probs...:-)

 

Regards,

Awaneesh Shatmanyu

 

 

-----Original Message-----
From: Devireddy, Nagendra Reddy (STSD) [mailto:[hidden email]]
Sent: Wednesday, March 01, 2006 1:23 PM
To: Tomcat Users List
Subject: Problem with Tomcat upgrade to 5.0.28 from 4.x

 

Hi,

 

I have upgraded tomcat from 4.x to 5.0.

This is how I hv done the upgrade ..

I took backup of webapps/test_apps

Installed Tomcat 5.0 and

Then I copied the test_apps to the new webapps

 

I have not changed any thing else ..

 

Tomcat is throwing class defination not found error .. But I searched

for the same class and its available in

test_apps/WEB-INF/lib/test_apps.jar

 

Do we need to change web.xml ?? Or the same which was working with 4.0

will work here ??

 

Is there any extra configuration needs to be changed ??

 

Please help me ..

 

Thanks,

Nagendra

 

---------------------------------------------------------------------

To unsubscribe, e-mail: [hidden email]

For additional commands, e-mail: [hidden email]

 

 


This email may contain confidential or privileged information for the
intended recipient(s) and the views expressed in the same are not
necessarily the views of Zensar Technologies Ltd. If you are not the intended
recipient or have received this e-mail by error, its use is strictly
prohibited, please delete the e-mail and notify the sender. Zensar
Technologies Ltd. does not accept any liability for virus infected mails.