Request body is empty in Tomcat 9.0.38

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Request body is empty in Tomcat 9.0.38

Jonnalagadda, Swathi (External)
Hi

We have a web application deployed in tomcat9.0.38 which is invoking a web service which is again deployed in another tomcat instance of 9.0.38

We are using httpclient to post request to webservice from the webapplication  and we could see that the request is reaching the webservice instance but the request body is all empty due to which the webservice is not able to read the request from client.

Could you please suggest if there is any configuration missing out here.

Thanks
Swathi
Reply | Threaded
Open this post in threaded view
|

Re: Request body is empty in Tomcat 9.0.38

Mounika Reddy
Check if it's a malformed XML and namespaces qualified are right. If JSON
it's a different issue and without much info, I hardly think it's a tomcat
issue

On Wed, Jan 6, 2021, 7:51 AM Jonnalagadda, Swathi (External) <
[hidden email]> wrote:

> Hi
>
> We have a web application deployed in tomcat9.0.38 which is invoking a web
> service which is again deployed in another tomcat instance of 9.0.38
>
> We are using httpclient to post request to webservice from the
> webapplication  and we could see that the request is reaching the
> webservice instance but the request body is all empty due to which the
> webservice is not able to read the request from client.
>
> Could you please suggest if there is any configuration missing out here.
>
> Thanks
> Swathi
>
Reply | Threaded
Open this post in threaded view
|

Re: Request body is empty in Tomcat 9.0.38

Mounika Reddy
If you can see the WSDL for the service assuming its a SOAP, then you can
actually generate a sample client XML using SOAP GUI clients and verify if
the service is actually deployed correctly

On Wed, Jan 6, 2021, 7:59 AM Mounika Reddy <[hidden email]> wrote:

> Check if it's a malformed XML and namespaces qualified are right. If JSON
> it's a different issue and without much info, I hardly think it's a tomcat
> issue
>
> On Wed, Jan 6, 2021, 7:51 AM Jonnalagadda, Swathi (External) <
> [hidden email]> wrote:
>
>> Hi
>>
>> We have a web application deployed in tomcat9.0.38 which is invoking a
>> web service which is again deployed in another tomcat instance of 9.0.38
>>
>> We are using httpclient to post request to webservice from the
>> webapplication  and we could see that the request is reaching the
>> webservice instance but the request body is all empty due to which the
>> webservice is not able to read the request from client.
>>
>> Could you please suggest if there is any configuration missing out here.
>>
>> Thanks
>> Swathi
>>
>