Tomcat is starting but unable to launch homepage in Linux. When launched from a browser from local machine it keep on rotating.

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Tomcat is starting but unable to launch homepage in Linux. When launched from a browser from local machine it keep on rotating.

Chaitanya Sabbineni
Hi All,

Can anyone please help me with the issue

I installed tomcat on Linux server and I deployed my application on tomcat.
Tomcat is starting fine and I can confirm this as in the tomcat log I can
see server started in 1234 milliseconds.
When I try to launch the tomcat homepage from my local machine it not
opening but keep on rotating.

I configured tomcat to listen on port 8083.
I executed the command curl -v http:// verb.pass.com:8083 and I am able to
get response.

Even I tried wget http:// verb.pass.com:8083 and I got response too.

When I tried telnet to the port from my local machine it's failed.
telnet verb.pass.com 8083

Failed on port 8083.

Can anyone please let me know why I am not able to launch the home page.

Thanks & Regards,
Chaitanya
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tomcat is starting but unable to launch homepage in Linux. When launched from a browser from local machine it keep on rotating.

M. Manna
What happens if you use the Tomcat default settings - not using 8083 port?
Does that work?

On 31 July 2017 at 18:18, Chaitanya Sabbineni <[hidden email]> wrote:

> Hi All,
>
> Can anyone please help me with the issue
>
> I installed tomcat on Linux server and I deployed my application on tomcat.
> Tomcat is starting fine and I can confirm this as in the tomcat log I can
> see server started in 1234 milliseconds.
> When I try to launch the tomcat homepage from my local machine it not
> opening but keep on rotating.
>
> I configured tomcat to listen on port 8083.
> I executed the command curl -v http:// verb.pass.com:8083 and I am able to
> get response.
>
> Even I tried wget http:// verb.pass.com:8083 and I got response too.
>
> When I tried telnet to the port from my local machine it's failed.
> telnet verb.pass.com 8083
>
> Failed on port 8083.
>
> Can anyone please let me know why I am not able to launch the home page.
>
> Thanks & Regards,
> Chaitanya
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tomcat is starting but unable to launch homepage in Linux. When launched from a browser from local machine it keep on rotating.

Chaitanya Sabbineni
Hi All,

Even though I use tomcat default port 8080 it's the same I am able to do
wget and curl but when launching the ui from local Windows machine it's
keep on rotating but never opens

Thanks in advance

On Mon, 31 Jul 2017 11:00 pm M. Manna, <[hidden email]> wrote:

> What happens if you use the Tomcat default settings - not using 8083 port?
> Does that work?
>
> On 31 July 2017 at 18:18, Chaitanya Sabbineni <[hidden email]>
> wrote:
>
> > Hi All,
> >
> > Can anyone please help me with the issue
> >
> > I installed tomcat on Linux server and I deployed my application on
> tomcat.
> > Tomcat is starting fine and I can confirm this as in the tomcat log I can
> > see server started in 1234 milliseconds.
> > When I try to launch the tomcat homepage from my local machine it not
> > opening but keep on rotating.
> >
> > I configured tomcat to listen on port 8083.
> > I executed the command curl -v http:// verb.pass.com:8083 and I am able
> to
> > get response.
> >
> > Even I tried wget http:// verb.pass.com:8083 and I got response too.
> >
> > When I tried telnet to the port from my local machine it's failed.
> > telnet verb.pass.com 8083
> >
> > Failed on port 8083.
> >
> > Can anyone please let me know why I am not able to launch the home page.
> >
> > Thanks & Regards,
> > Chaitanya
> >
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tomcat is starting but unable to launch homepage in Linux. When launched from a browser from local machine it keep on rotating.

M. Manna
Please share your server.xml and if possible. Also, does the request times
out with an error on the browser? if so, what is the error?
Can you do localhost:8083 on your Linux box?

On 31 July 2017 at 18:34, Chaitanya Sabbineni <[hidden email]> wrote:

> Hi All,
>
> Even though I use tomcat default port 8080 it's the same I am able to do
> wget and curl but when launching the ui from local Windows machine it's
> keep on rotating but never opens
>
> Thanks in advance
>
> On Mon, 31 Jul 2017 11:00 pm M. Manna, <[hidden email]> wrote:
>
> > What happens if you use the Tomcat default settings - not using 8083
> port?
> > Does that work?
> >
> > On 31 July 2017 at 18:18, Chaitanya Sabbineni <[hidden email]>
> > wrote:
> >
> > > Hi All,
> > >
> > > Can anyone please help me with the issue
> > >
> > > I installed tomcat on Linux server and I deployed my application on
> > tomcat.
> > > Tomcat is starting fine and I can confirm this as in the tomcat log I
> can
> > > see server started in 1234 milliseconds.
> > > When I try to launch the tomcat homepage from my local machine it not
> > > opening but keep on rotating.
> > >
> > > I configured tomcat to listen on port 8083.
> > > I executed the command curl -v http:// verb.pass.com:8083 and I am
> able
> > to
> > > get response.
> > >
> > > Even I tried wget http:// verb.pass.com:8083 and I got response too.
> > >
> > > When I tried telnet to the port from my local machine it's failed.
> > > telnet verb.pass.com 8083
> > >
> > > Failed on port 8083.
> > >
> > > Can anyone please let me know why I am not able to launch the home
> page.
> > >
> > > Thanks & Regards,
> > > Chaitanya
> > >
> >
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tomcat is starting but unable to launch homepage in Linux. When launched from a browser from local machine it keep on rotating.

Chaitanya Sabbineni
Hi All,

When I launched in browser request is not timed out. It just keep on
rotates but never opens.

In server.xml the ports that are configured are. 8006 shutdown port.
http port 8083
Https port 8443

Home page is not launching neither in http nor in https mode.

In Linux box I tried wget and curl commands and from Windows I tried telnet.

what actually you mean this how to do localhost:8083 on Linux box. You mean
to launch in same Linux internalbox using xgd http:// localhost:8083

Thanks




On Mon, 31 Jul 2017 11:09 pm M. Manna, <[hidden email]> wrote:

> Please share your server.xml and if possible. Also, does the request times
> out with an error on the browser? if so, what is the error?
> Can you do localhost:8083 on your Linux box?
>
> On 31 July 2017 at 18:34, Chaitanya Sabbineni <[hidden email]>
> wrote:
>
> > Hi All,
> >
> > Even though I use tomcat default port 8080 it's the same I am able to do
> > wget and curl but when launching the ui from local Windows machine it's
> > keep on rotating but never opens
> >
> > Thanks in advance
> >
> > On Mon, 31 Jul 2017 11:00 pm M. Manna, <[hidden email]> wrote:
> >
> > > What happens if you use the Tomcat default settings - not using 8083
> > port?
> > > Does that work?
> > >
> > > On 31 July 2017 at 18:18, Chaitanya Sabbineni <[hidden email]>
> > > wrote:
> > >
> > > > Hi All,
> > > >
> > > > Can anyone please help me with the issue
> > > >
> > > > I installed tomcat on Linux server and I deployed my application on
> > > tomcat.
> > > > Tomcat is starting fine and I can confirm this as in the tomcat log I
> > can
> > > > see server started in 1234 milliseconds.
> > > > When I try to launch the tomcat homepage from my local machine it not
> > > > opening but keep on rotating.
> > > >
> > > > I configured tomcat to listen on port 8083.
> > > > I executed the command curl -v http:// verb.pass.com:8083 and I am
> > able
> > > to
> > > > get response.
> > > >
> > > > Even I tried wget http:// verb.pass.com:8083 and I got response too.
> > > >
> > > > When I tried telnet to the port from my local machine it's failed.
> > > > telnet verb.pass.com 8083
> > > >
> > > > Failed on port 8083.
> > > >
> > > > Can anyone please let me know why I am not able to launch the home
> > page.
> > > >
> > > > Thanks & Regards,
> > > > Chaitanya
> > > >
> > >
> >
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Tomcat is starting but unable to launch homepage in Linux. When launched from a browser from local machine it keep on rotating.

Darvi Gill
Try disabling the firewall on the Linux server.

systemctl stop firewalld

Darvi Gill


-----Original Message-----
From: Chaitanya Sabbineni [mailto:[hidden email]]
Sent: Monday, July 31, 2017 11:46 AM
To: Tomcat Users List <[hidden email]>
Subject: Re: Tomcat is starting but unable to launch homepage in Linux. When launched from a browser from local machine it keep on rotating.

Hi All,

When I launched in browser request is not timed out. It just keep on rotates but never opens.

In server.xml the ports that are configured are. 8006 shutdown port.
http port 8083
Https port 8443

Home page is not launching neither in http nor in https mode.

In Linux box I tried wget and curl commands and from Windows I tried telnet.

what actually you mean this how to do localhost:8083 on Linux box. You mean to launch in same Linux internalbox using xgd http:// localhost:8083

Thanks




On Mon, 31 Jul 2017 11:09 pm M. Manna, <[hidden email]> wrote:

> Please share your server.xml and if possible. Also, does the request
> times out with an error on the browser? if so, what is the error?
> Can you do localhost:8083 on your Linux box?
>
> On 31 July 2017 at 18:34, Chaitanya Sabbineni <[hidden email]>
> wrote:
>
> > Hi All,
> >
> > Even though I use tomcat default port 8080 it's the same I am able
> > to do wget and curl but when launching the ui from local Windows
> > machine it's keep on rotating but never opens
> >
> > Thanks in advance
> >
> > On Mon, 31 Jul 2017 11:00 pm M. Manna, <[hidden email]> wrote:
> >
> > > What happens if you use the Tomcat default settings - not using
> > > 8083
> > port?
> > > Does that work?
> > >
> > > On 31 July 2017 at 18:18, Chaitanya Sabbineni
> > > <[hidden email]>
> > > wrote:
> > >
> > > > Hi All,
> > > >
> > > > Can anyone please help me with the issue
> > > >
> > > > I installed tomcat on Linux server and I deployed my application
> > > > on
> > > tomcat.
> > > > Tomcat is starting fine and I can confirm this as in the tomcat
> > > > log I
> > can
> > > > see server started in 1234 milliseconds.
> > > > When I try to launch the tomcat homepage from my local machine
> > > > it not opening but keep on rotating.
> > > >
> > > > I configured tomcat to listen on port 8083.
> > > > I executed the command curl -v http:// verb.pass.com:8083 and I
> > > > am
> > able
> > > to
> > > > get response.
> > > >
> > > > Even I tried wget http:// verb.pass.com:8083 and I got response too.
> > > >
> > > > When I tried telnet to the port from my local machine it's failed.
> > > > telnet verb.pass.com 8083
> > > >
> > > > Failed on port 8083.
> > > >
> > > > Can anyone please let me know why I am not able to launch the
> > > > home
> > page.
> > > >
> > > > Thanks & Regards,
> > > > Chaitanya
> > > >
> > >
> >
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tomcat is starting but unable to launch homepage in Linux. When launched from a browser from local machine it keep on rotating.

Chaitanya Sabbineni
Hi,

You mean some fire wall is blocking the request on that port

systemctl stop firewalld will disable that firewall.


On Mon, 31 Jul 2017 11:20 pm Darvi Gill, <[hidden email]> wrote:

> Try disabling the firewall on the Linux server.
>
> systemctl stop firewalld
>
> Darvi Gill
>
>
> -----Original Message-----
> From: Chaitanya Sabbineni [mailto:[hidden email]]
> Sent: Monday, July 31, 2017 11:46 AM
> To: Tomcat Users List <[hidden email]>
> Subject: Re: Tomcat is starting but unable to launch homepage in Linux.
> When launched from a browser from local machine it keep on rotating.
>
> Hi All,
>
> When I launched in browser request is not timed out. It just keep on
> rotates but never opens.
>
> In server.xml the ports that are configured are. 8006 shutdown port.
> http port 8083
> Https port 8443
>
> Home page is not launching neither in http nor in https mode.
>
> In Linux box I tried wget and curl commands and from Windows I tried
> telnet.
>
> what actually you mean this how to do localhost:8083 on Linux box. You
> mean to launch in same Linux internalbox using xgd http:// localhost:8083
>
> Thanks
>
>
>
>
> On Mon, 31 Jul 2017 11:09 pm M. Manna, <[hidden email]> wrote:
>
> > Please share your server.xml and if possible. Also, does the request
> > times out with an error on the browser? if so, what is the error?
> > Can you do localhost:8083 on your Linux box?
> >
> > On 31 July 2017 at 18:34, Chaitanya Sabbineni <[hidden email]>
> > wrote:
> >
> > > Hi All,
> > >
> > > Even though I use tomcat default port 8080 it's the same I am able
> > > to do wget and curl but when launching the ui from local Windows
> > > machine it's keep on rotating but never opens
> > >
> > > Thanks in advance
> > >
> > > On Mon, 31 Jul 2017 11:00 pm M. Manna, <[hidden email]> wrote:
> > >
> > > > What happens if you use the Tomcat default settings - not using
> > > > 8083
> > > port?
> > > > Does that work?
> > > >
> > > > On 31 July 2017 at 18:18, Chaitanya Sabbineni
> > > > <[hidden email]>
> > > > wrote:
> > > >
> > > > > Hi All,
> > > > >
> > > > > Can anyone please help me with the issue
> > > > >
> > > > > I installed tomcat on Linux server and I deployed my application
> > > > > on
> > > > tomcat.
> > > > > Tomcat is starting fine and I can confirm this as in the tomcat
> > > > > log I
> > > can
> > > > > see server started in 1234 milliseconds.
> > > > > When I try to launch the tomcat homepage from my local machine
> > > > > it not opening but keep on rotating.
> > > > >
> > > > > I configured tomcat to listen on port 8083.
> > > > > I executed the command curl -v http:// verb.pass.com:8083 and I
> > > > > am
> > > able
> > > > to
> > > > > get response.
> > > > >
> > > > > Even I tried wget http:// verb.pass.com:8083 and I got response
> too.
> > > > >
> > > > > When I tried telnet to the port from my local machine it's failed.
> > > > > telnet verb.pass.com 8083
> > > > >
> > > > > Failed on port 8083.
> > > > >
> > > > > Can anyone please let me know why I am not able to launch the
> > > > > home
> > > page.
> > > > >
> > > > > Thanks & Regards,
> > > > > Chaitanya
> > > > >
> > > >
> > >
> >
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Tomcat is starting but unable to launch homepage in Linux. When launched from a browser from local machine it keep on rotating.

Darvi Gill
Yes.

 Firewall maybe blocking access to the ports local on the server and external. Depending on the version of Linux

The command will stop the firewall; until you start it again "systemctl start  firewalld"  or  reboot server.

This is the command to disable:  systemctl disbale firewalld
-----Original Message-----
From: Chaitanya Sabbineni [mailto:[hidden email]]
Sent: Monday, July 31, 2017 11:52 AM
To: Tomcat Users List <[hidden email]>
Subject: Re: Tomcat is starting but unable to launch homepage in Linux. When launched from a browser from local machine it keep on rotating.

Hi,

You mean some fire wall is blocking the request on that port

systemctl stop firewalld will disable that firewall.


On Mon, 31 Jul 2017 11:20 pm Darvi Gill, <[hidden email]> wrote:

> Try disabling the firewall on the Linux server.
>
> systemctl stop firewalld
>
> Darvi Gill
>
>
> -----Original Message-----
> From: Chaitanya Sabbineni [mailto:[hidden email]]
> Sent: Monday, July 31, 2017 11:46 AM
> To: Tomcat Users List <[hidden email]>
> Subject: Re: Tomcat is starting but unable to launch homepage in Linux.
> When launched from a browser from local machine it keep on rotating.
>
> Hi All,
>
> When I launched in browser request is not timed out. It just keep on
> rotates but never opens.
>
> In server.xml the ports that are configured are. 8006 shutdown port.
> http port 8083
> Https port 8443
>
> Home page is not launching neither in http nor in https mode.
>
> In Linux box I tried wget and curl commands and from Windows I tried
> telnet.
>
> what actually you mean this how to do localhost:8083 on Linux box. You
> mean to launch in same Linux internalbox using xgd http://
> localhost:8083
>
> Thanks
>
>
>
>
> On Mon, 31 Jul 2017 11:09 pm M. Manna, <[hidden email]> wrote:
>
> > Please share your server.xml and if possible. Also, does the request
> > times out with an error on the browser? if so, what is the error?
> > Can you do localhost:8083 on your Linux box?
> >
> > On 31 July 2017 at 18:34, Chaitanya Sabbineni
> > <[hidden email]>
> > wrote:
> >
> > > Hi All,
> > >
> > > Even though I use tomcat default port 8080 it's the same I am able
> > > to do wget and curl but when launching the ui from local Windows
> > > machine it's keep on rotating but never opens
> > >
> > > Thanks in advance
> > >
> > > On Mon, 31 Jul 2017 11:00 pm M. Manna, <[hidden email]> wrote:
> > >
> > > > What happens if you use the Tomcat default settings - not using
> > > > 8083
> > > port?
> > > > Does that work?
> > > >
> > > > On 31 July 2017 at 18:18, Chaitanya Sabbineni
> > > > <[hidden email]>
> > > > wrote:
> > > >
> > > > > Hi All,
> > > > >
> > > > > Can anyone please help me with the issue
> > > > >
> > > > > I installed tomcat on Linux server and I deployed my
> > > > > application on
> > > > tomcat.
> > > > > Tomcat is starting fine and I can confirm this as in the
> > > > > tomcat log I
> > > can
> > > > > see server started in 1234 milliseconds.
> > > > > When I try to launch the tomcat homepage from my local machine
> > > > > it not opening but keep on rotating.
> > > > >
> > > > > I configured tomcat to listen on port 8083.
> > > > > I executed the command curl -v http:// verb.pass.com:8083 and
> > > > > I am
> > > able
> > > > to
> > > > > get response.
> > > > >
> > > > > Even I tried wget http:// verb.pass.com:8083 and I got
> > > > > response
> too.
> > > > >
> > > > > When I tried telnet to the port from my local machine it's failed.
> > > > > telnet verb.pass.com 8083
> > > > >
> > > > > Failed on port 8083.
> > > > >
> > > > > Can anyone please let me know why I am not able to launch the
> > > > > home
> > > page.
> > > > >
> > > > > Thanks & Regards,
> > > > > Chaitanya
> > > > >
> > > >
> > >
> >
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tomcat is starting but unable to launch homepage in Linux. When launched from a browser from local machine it keep on rotating.

M. Manna
In reply to this post by Chaitanya Sabbineni
If you are using Ubuntu Linux, I am assuming that you have a desktop
option? If so, could you open a browser and check if you can use
localhost:8083 to see if the page loads from the box itself.

How have you configured your server.xml file? without looking at the
server.xml it's not clear how you have configured it? What you are
mentioning above is the responsiveness of the server url against the port
number. But I cannot see anywhere the web deployment directory structure
i.e. how your welcome file and everything is configured to be loaded.



Kindest Regards,

On 31 July 2017 at 18:46, Chaitanya Sabbineni <[hidden email]> wrote:

> Hi All,
>
> When I launched in browser request is not timed out. It just keep on
> rotates but never opens.
>
> In server.xml the ports that are configured are. 8006 shutdown port.
> http port 8083
> Https port 8443
>
> Home page is not launching neither in http nor in https mode.
>
> In Linux box I tried wget and curl commands and from Windows I tried
> telnet.
>
> what actually you mean this how to do localhost:8083 on Linux box. You mean
> to launch in same Linux internalbox using xgd http:// localhost:8083
>
> Thanks
>
>
>
>
> On Mon, 31 Jul 2017 11:09 pm M. Manna, <[hidden email]> wrote:
>
> > Please share your server.xml and if possible. Also, does the request
> times
> > out with an error on the browser? if so, what is the error?
> > Can you do localhost:8083 on your Linux box?
> >
> > On 31 July 2017 at 18:34, Chaitanya Sabbineni <[hidden email]>
> > wrote:
> >
> > > Hi All,
> > >
> > > Even though I use tomcat default port 8080 it's the same I am able to
> do
> > > wget and curl but when launching the ui from local Windows machine it's
> > > keep on rotating but never opens
> > >
> > > Thanks in advance
> > >
> > > On Mon, 31 Jul 2017 11:00 pm M. Manna, <[hidden email]> wrote:
> > >
> > > > What happens if you use the Tomcat default settings - not using 8083
> > > port?
> > > > Does that work?
> > > >
> > > > On 31 July 2017 at 18:18, Chaitanya Sabbineni <[hidden email]
> >
> > > > wrote:
> > > >
> > > > > Hi All,
> > > > >
> > > > > Can anyone please help me with the issue
> > > > >
> > > > > I installed tomcat on Linux server and I deployed my application on
> > > > tomcat.
> > > > > Tomcat is starting fine and I can confirm this as in the tomcat
> log I
> > > can
> > > > > see server started in 1234 milliseconds.
> > > > > When I try to launch the tomcat homepage from my local machine it
> not
> > > > > opening but keep on rotating.
> > > > >
> > > > > I configured tomcat to listen on port 8083.
> > > > > I executed the command curl -v http:// verb.pass.com:8083 and I am
> > > able
> > > > to
> > > > > get response.
> > > > >
> > > > > Even I tried wget http:// verb.pass.com:8083 and I got response
> too.
> > > > >
> > > > > When I tried telnet to the port from my local machine it's failed.
> > > > > telnet verb.pass.com 8083
> > > > >
> > > > > Failed on port 8083.
> > > > >
> > > > > Can anyone please let me know why I am not able to launch the home
> > > page.
> > > > >
> > > > > Thanks & Regards,
> > > > > Chaitanya
> > > > >
> > > >
> > >
> >
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tomcat is starting but unable to launch homepage in Linux. When launched from a browser from local machine it keep on rotating.

Mark Eggers
In reply to this post by Chaitanya Sabbineni
Chaitanya,

On 7/31/2017 10:34 AM, Chaitanya Sabbineni wrote:

> Hi All,
>
> Even though I use tomcat default port 8080 it's the same I am able to do
> wget and curl but when launching the ui from local Windows machine it's
> keep on rotating but never opens
>
> Thanks in advance
>
> On Mon, 31 Jul 2017 11:00 pm M. Manna, <[hidden email]> wrote:
>
>> What happens if you use the Tomcat default settings - not using 8083 port?
>> Does that work?
>>
>> On 31 July 2017 at 18:18, Chaitanya Sabbineni <[hidden email]>
>> wrote:
>>
>>> Hi All,
>>>
>>> Can anyone please help me with the issue
>>>
>>> I installed tomcat on Linux server and I deployed my application on
>> tomcat.
>>> Tomcat is starting fine and I can confirm this as in the tomcat log I can
>>> see server started in 1234 milliseconds.
>>> When I try to launch the tomcat homepage from my local machine it not
>>> opening but keep on rotating.
>>>
>>> I configured tomcat to listen on port 8083.
>>> I executed the command curl -v http:// verb.pass.com:8083 and I am able
>> to
>>> get response.
>>>
>>> Even I tried wget http:// verb.pass.com:8083 and I got response too.
>>>
>>> When I tried telnet to the port from my local machine it's failed.
>>> telnet verb.pass.com 8083
>>>
>>> Failed on port 8083.
>>>
>>> Can anyone please let me know why I am not able to launch the home page.
>>>
>>> Thanks & Regards,
>>> Chaitanya
>>>
>>
>
Silly question: Is verb.pass.com in DNS anywhere?

If not, you'll have to edit your Windows host file to include the IP
address.

Also, as others have pointed out you may have a firewall issue that
prevents remote connections to port 8080 (or 8083).

. . . just my two cents
/mde/


signature.asc (484 bytes) Download Attachment
Loading...