[tomcat] branch 9.0.x updated (b691d0d -> ed0517f)

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[tomcat] branch 9.0.x updated (b691d0d -> ed0517f)

markt
This is an automated email from the ASF dual-hosted git repository.

markt pushed a change to branch 9.0.x
in repository https://gitbox.apache.org/repos/asf/tomcat.git.


    from b691d0d  Remove unnecessary space
     new cad53f6  Update ECJ to 4.18
     new ed0517f  Use new constants available in ECJ 4.18

The 2 revisions listed above as "new" are entirely new to this
repository and will be described in separate emails.  The revisions
listed as "add" were already present in the repository and have only
been added to this reference.


Summary of changes:
 build.properties.default                            | 12 ++++++------
 java/org/apache/jasper/compiler/JDTCompiler.java    | 12 +++---------
 res/ide-support/eclipse/eclipse.classpath           |  2 +-
 res/ide-support/idea/tomcat.iml                     |  2 +-
 res/ide-support/netbeans/nb-tomcat-build.properties |  2 +-
 res/ide-support/netbeans/project.xml                |  2 +-
 res/maven/tomcat-jasper.pom                         |  2 +-
 webapps/docs/changelog.xml                          |  3 +++
 8 files changed, 17 insertions(+), 20 deletions(-)


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[tomcat] 01/02: Update ECJ to 4.18

markt
This is an automated email from the ASF dual-hosted git repository.

markt pushed a commit to branch 9.0.x
in repository https://gitbox.apache.org/repos/asf/tomcat.git

commit cad53f67e570e024f75a33beb8b587a119fb13ab
Author: Mark Thomas <[hidden email]>
AuthorDate: Tue Jan 5 17:46:42 2021 +0000

    Update ECJ to 4.18
---
 build.properties.default                            | 12 ++++++------
 res/ide-support/eclipse/eclipse.classpath           |  2 +-
 res/ide-support/idea/tomcat.iml                     |  2 +-
 res/ide-support/netbeans/nb-tomcat-build.properties |  2 +-
 res/ide-support/netbeans/project.xml                |  2 +-
 res/maven/tomcat-jasper.pom                         |  2 +-
 webapps/docs/changelog.xml                          |  3 +++
 7 files changed, 14 insertions(+), 11 deletions(-)

diff --git a/build.properties.default b/build.properties.default
index 4025321..61f1345 100644
--- a/build.properties.default
+++ b/build.properties.default
@@ -129,15 +129,15 @@ wsdl4j-lib.loc=${base-maven.loc}/wsdl4j/wsdl4j/${wsdl4j-lib.version}/wsdl4j-${ws
 # ----- Eclipse JDT, version 4.7 or later -----#
 # See https://cwiki.apache.org/confluence/display/TOMCAT/Managing+Tomcat%27s+Dependency+on+the+Eclipse+JDT+Core+Batch+Compiler
 #
-# Checksum is from "SHA512 Checksums for 4.17" link at
-# http://download.eclipse.org/eclipse/downloads/drops4/R-4.17-202009021800/
-# http://download.eclipse.org/eclipse/downloads/drops4/R-4.17-202009021800/checksum/eclipse-4.17-SUMSSHA512
+# Checksum is from "SHA512 Checksums for 4.18" link at
+# https://download.eclipse.org/eclipse/downloads/drops4/R-4.18-202012021800/
+# https://download.eclipse.org/eclipse/downloads/drops4/R-4.18-202012021800/checksum/eclipse-4.18-SUMSSHA512
 #
-jdt.version=4.17
-jdt.release=R-4.17-202009021800
+jdt.version=4.18
+jdt.release=R-4.18-202012021800
 jdt.checksum.enabled=true
 jdt.checksum.algorithm=SHA-512
-jdt.checksum.value=5e63e06eccd76a61249c7c6bd97e5b77dc37335bfdf316d941b00a16bae4f152d4306bac4e45c8422976187b0d77fe30cf7e6f6d4425f7732a3cb0cfa954385b
+jdt.checksum.value=d63891e8da5dd4d26a48bbc9c1ddb8f2ba9a13c9a8a05a5b5e31eb2e72f79fbedccaad501fc92ca622701052a519051c31dd232dcdf6bf504478fbfd08a840e8
 jdt.home=${base.path}/ecj-${jdt.version}
 jdt.jar=${jdt.home}/ecj-${jdt.version}.jar
 # The download will be moved to the archive area eventually. We are taking care of that in advance.
diff --git a/res/ide-support/eclipse/eclipse.classpath b/res/ide-support/eclipse/eclipse.classpath
index d298189..be94f08 100644
--- a/res/ide-support/eclipse/eclipse.classpath
+++ b/res/ide-support/eclipse/eclipse.classpath
@@ -24,7 +24,7 @@
     <classpathentry kind="var" path="ANT_HOME/lib/ant.jar"/>
     <classpathentry kind="var" path="TOMCAT_LIBS_BASE/jaxrpc-1.1-rc4/geronimo-spec-jaxrpc-1.1-rc4.jar"/>
     <classpathentry kind="var" path="TOMCAT_LIBS_BASE/wsdl4j-1.6.3/wsdl4j-1.6.3.jar"/>
-    <classpathentry kind="var" path="TOMCAT_LIBS_BASE/ecj-4.17/ecj-4.17.jar"/>
+    <classpathentry kind="var" path="TOMCAT_LIBS_BASE/ecj-4.18/ecj-4.18.jar"/>
     <classpathentry kind="var" path="TOMCAT_LIBS_BASE/easymock-4.2/easymock-4.2.jar"/>
     <classpathentry kind="var" path="TOMCAT_LIBS_BASE/hamcrest-2.2/hamcrest-2.2.jar"/>
     <classpathentry kind="var" path="TOMCAT_LIBS_BASE/cglib-3.3.0/cglib-nodep-3.3.0.jar"/>
diff --git a/res/ide-support/idea/tomcat.iml b/res/ide-support/idea/tomcat.iml
index e749442..a1ca45a 100644
--- a/res/ide-support/idea/tomcat.iml
+++ b/res/ide-support/idea/tomcat.iml
@@ -68,7 +68,7 @@
     <orderEntry type="module-library">
       <library>
         <CLASSES>
-          <root url="jar://$TOMCAT_BUILD_LIBS$/ecj-4.17/ecj-4.17.jar!/" />
+          <root url="jar://$TOMCAT_BUILD_LIBS$/ecj-4.18/ecj-4.18.jar!/" />
         </CLASSES>
         <JAVADOC />
         <SOURCES />
diff --git a/res/ide-support/netbeans/nb-tomcat-build.properties b/res/ide-support/netbeans/nb-tomcat-build.properties
index 3400b83..337e797 100644
--- a/res/ide-support/netbeans/nb-tomcat-build.properties
+++ b/res/ide-support/netbeans/nb-tomcat-build.properties
@@ -37,7 +37,7 @@ nb-test.io-method=org.apache.coyote.http11.Http11NioProtocol
 # it is not possible to retrieve the classpaths from the build to
 # use in the NetBeans targets, so they must be explicitly declared
 
-nb-test.classpath=${test.classes}:${tomcat.build}/webapps/examples/WEB-INF/classes:${base.path}/junit-4.13/junit-4.13.jar:${base.path}/easymock-4.2/easymock-4.2.jar:${base.path}/objenesis-3.1/objenesis-3.1.jar:${base.path}/cglib-3.3.0/cglib-nodep-3.3.0.jar:${base.path}/hamcrest-2.2/hamcrest-2.2.jar:${base.path}/ecj-4.17/ecj-4.17.jar:${tomcat.classes}
+nb-test.classpath=${test.classes}:${tomcat.build}/webapps/examples/WEB-INF/classes:${base.path}/junit-4.13/junit-4.13.jar:${base.path}/easymock-4.2/easymock-4.2.jar:${base.path}/objenesis-3.1/objenesis-3.1.jar:${base.path}/cglib-3.3.0/cglib-nodep-3.3.0.jar:${base.path}/hamcrest-2.2/hamcrest-2.2.jar:${base.path}/ecj-4.18/ecj-4.18.jar:${tomcat.classes}
 
 # Extra properties used by the Tomcat project additional NetBeans targets.
 
diff --git a/res/ide-support/netbeans/project.xml b/res/ide-support/netbeans/project.xml
index 498fd3a..28d2a74 100644
--- a/res/ide-support/netbeans/project.xml
+++ b/res/ide-support/netbeans/project.xml
@@ -178,7 +178,7 @@
             -->
             <compilation-unit>
                 <package-root>java</package-root>
-                <classpath mode="compile">${base.path}/jaxrpc-1.1-rc4/geronimo-spec-jaxrpc-1.1-rc4.jar:${base.path}/wsdl4j-1.6.3/wsdl4j-1.6.3.jar:${base.path}/ecj-4.17/ecj-4.17.jar:${base.path}/bnd-5.3.0-SNAPSHOT/biz.aQute.bnd-5.3.0-SNAPSHOT.jar:${ant.includes}/</classpath>
+                <classpath mode="compile">${base.path}/jaxrpc-1.1-rc4/geronimo-spec-jaxrpc-1.1-rc4.jar:${base.path}/wsdl4j-1.6.3/wsdl4j-1.6.3.jar:${base.path}/ecj-4.18/ecj-4.18.jar:${base.path}/bnd-5.3.0-SNAPSHOT/biz.aQute.bnd-5.3.0-SNAPSHOT.jar:${ant.includes}/</classpath>
                 <source-level>1.7</source-level>
             </compilation-unit>
             <compilation-unit>
diff --git a/res/maven/tomcat-jasper.pom b/res/maven/tomcat-jasper.pom
index aa95105..8a68faf 100644
--- a/res/maven/tomcat-jasper.pom
+++ b/res/maven/tomcat-jasper.pom
@@ -60,7 +60,7 @@
     <dependency>
       <groupId>org.eclipse.jdt</groupId>
       <artifactId>ecj</artifactId>
-      <version>3.23.0</version>
+      <version>3.24.0</version>
     </dependency>
     <dependency>
       <groupId>org.apache.tomcat</groupId>
diff --git a/webapps/docs/changelog.xml b/webapps/docs/changelog.xml
index 43464f7..2db2cf8 100644
--- a/webapps/docs/changelog.xml
+++ b/webapps/docs/changelog.xml
@@ -176,6 +176,9 @@
         ignore expired sessions rather than throw an
         <code>IllegalStateException</code>. (remm)
       </fix>
+      <update>
+        Update to the Eclipse JDT compiler 4.18. (markt)
+      </update>
     </changelog>
   </subsection>
   <subsection name="Web applications">


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[tomcat] 02/02: Use new constants available in ECJ 4.18

markt
In reply to this post by markt
This is an automated email from the ASF dual-hosted git repository.

markt pushed a commit to branch 9.0.x
in repository https://gitbox.apache.org/repos/asf/tomcat.git

commit ed0517f207cc8f92cf88baad8e0ad409e4fbfd93
Author: Mark Thomas <[hidden email]>
AuthorDate: Tue Jan 5 17:49:02 2021 +0000

    Use new constants available in ECJ 4.18
---
 java/org/apache/jasper/compiler/JDTCompiler.java | 12 +++---------
 1 file changed, 3 insertions(+), 9 deletions(-)

diff --git a/java/org/apache/jasper/compiler/JDTCompiler.java b/java/org/apache/jasper/compiler/JDTCompiler.java
index 4c7d3bd..ebc00f6 100644
--- a/java/org/apache/jasper/compiler/JDTCompiler.java
+++ b/java/org/apache/jasper/compiler/JDTCompiler.java
@@ -308,10 +308,7 @@ public class JDTCompiler extends org.apache.jasper.compiler.Compiler {
             } else if(opt.equals("14")) {
                 settings.put(CompilerOptions.OPTION_Source, CompilerOptions.VERSION_14);
             } else if(opt.equals("15")) {
-                // Constant not available in latest ECJ version shipped with
-                // Tomcat. May be supported in a snapshot build.
-                // This is checked against the actual version below.
-                settings.put(CompilerOptions.OPTION_Source, "15");
+                settings.put(CompilerOptions.OPTION_Source, CompilerOptions.VERSION_15);
             } else if(opt.equals("16")) {
                 // Constant not available in latest ECJ version shipped with
                 // Tomcat. May be supported in a snapshot build.
@@ -370,11 +367,8 @@ public class JDTCompiler extends org.apache.jasper.compiler.Compiler {
                 settings.put(CompilerOptions.OPTION_TargetPlatform, CompilerOptions.VERSION_14);
                 settings.put(CompilerOptions.OPTION_Compliance, CompilerOptions.VERSION_14);
             } else if(opt.equals("15")) {
-                // Constant not available in latest ECJ version shipped with
-                // Tomcat. May be supported in a snapshot build.
-                // This is checked against the actual version below.
-                settings.put(CompilerOptions.OPTION_TargetPlatform, "15");
-                settings.put(CompilerOptions.OPTION_Compliance, "15");
+                settings.put(CompilerOptions.OPTION_TargetPlatform, CompilerOptions.VERSION_15);
+                settings.put(CompilerOptions.OPTION_Compliance, CompilerOptions.VERSION_15);
             } else if(opt.equals("16")) {
                 // Constant not available in latest ECJ version shipped with
                 // Tomcat. May be supported in a snapshot build.


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]